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Excel search different sheets

Watch the video – Comparing two Excel sheets to differences Comparing two Excel files (or comparing two sheets in the same file) can be tricky because an Excel workbook displays only one sheet at a time. This becomes more difficult and is prone to errors when you have a lot of comparing data. Fortunately, Excel has
some great features that allow you to open and easily compare two Excel files. In this Excel tutorial, I will show you several ways to compare two different Excel files (or tables) and check the differences. The method you choose depends on how your data is structured and what kind of comparison you're looking for. Let's
start! Compare two Excel sheets in separate Excel files (side by side) To compare two separate Excel files side by side (or two sheets in the same workbook), Excel has a built-in feature for this purpose. It's the Show side-by-side option. This is only recommended when you have a small dataset and the manual
comparison of these files is likely to be less time-consuming and error-prone. If you have a large dataset, I recommend using a conditional method or formula method that is covered later in this tutorial. Let's see how to use this when you need to compare two separate files or two sheets in the same file. For example, you
assume you have two files for two different months and want to check which values are different for those two files. When you open a file, it will most likely take up the entire screen. Even if you reduce the size, you will always see one excel file at the top. You can use view side-by-side to open two files, and then arrange
them horizontally or vertically. This allows you to easily compare values without switching back and forth. Below are the steps that align two files side by side and compare them: Open the files you want to compare. For each file, select the table that you want to compare. Click the View tab in the Click Show Side by Side
option in the Windows group. This is available only when you have two or more Excel files open. As soon as you click Show Side by Side, Excel arranges the workbook horizontally. Both files are visible, and you are free to edit/compare these files when arranged side by side. To arrange files vertically, click Arrange All
(on the View tab). This opens the Organize Windows dialog box, where you can click Vertical. At this point, if you scroll down on a worksheet, the other remains the same. You can change this so that when you scroll one table, the other scrolls at the same time. This makes it easier to make a line comparison and detect
differences. But to do this, you need to enable synchronous scrolling. To turn on synchronous scrolling, click the View tab (in any workbook), and then click scroll option. This is the to change button (so if you want to turn it off, just click on it When you compare multiple tables in separate Excel files (side by side) with the
Show Side by Side option, you can only compare two Excel files at once. If you have multiple Excel files open when you click Show Side by Side, it displays the Compare Side by Side dialog box, where you can choose which file you want to compare with the active workbook. To compare more than two files at a time,
open all of these files, and then click Arrange All (it's on the View tab). In the Arrange Windows dialog box, click Portrait/Landscape, and then click OK. Compare two tables (side by side) in the same Excel workbook To compare two separate sheets in the same workbook, you cannot use the Show Side by Side property
(because it works only in separate Excel files). But you can still make the same parallel comparison. This is made possible by the New Windows feature in Excel, which allows you to open two instances in the same workbook. When two instances are open, you can arrange them side by side and compare them. Let's say
you have an Excel workbook with two tables for two different months (January and February) and want to compare them side by side to see how store-specific sales have changed: Below are the steps to compare two tables in Excel: Open a workbook with comparative tables. Click the View tab in the Window group,

then click New Window. This opens another instance of the same workbook. On the View tab, click Arrange All. This opens the Arrange Windows dialog box Click Vertical to compare data in columns (or horizontal to compare data in rows). Click OK. The steps above arrange both instances of the workbook vertically. At
this point, both workbooks would have the same worksheet selected. In one workbook, select another sheet that you want to compare with the active sheet. How does this work? When you click New Window, it reopens the same workbook with a slightly different name. For example, if the workbook is called Test and you
click New Window, it already names Test – 1 for the open workbook and Test - 2 for another instance. Note that these are still the same workbook. If you make changes to any of these workbooks, it will appear in both. When you close any instance of an open file, the name returns to its original. You can also turn on
synchronous scrolling if you want (by clicking synchronous scrolling on the View tab) Compare two tables and highlight differences (using conditional formatting) Although you can use the above method to level workbooks together and manually go through a row of data line, it's not a good way if you have a lot of data.
Manual comparison of this reference level may also: Instead of doing this manually, you can use the power of conditional formatting to quickly highlight the potential differences between two Excel sheets. This method is really useful if you have two versions on two different forms and want to quickly check what has
changed. Note that you cannot compare two tables in different workbooks. Because conditional formatting cannot refer to an external Excel file, the tables you want to compare must be in the same Excel workbook. If not, you can copy the table from the file to the active workbook, on the other hand, and then make this
comparison. For example, let's say you have the dataset shown below for two months (January and February) in two different tables, and you want to quickly compare the data on these two sheets to see if the prices for these items have changed or not. Here are the steps to do this: Select the data in the table where you
want to highlight your changes. Since I want to check how prices have changed from January to February, I have selected the data from the February table. On the Home tab, in the Styles group, select Conditional Formatting Click on 'New Rule' in the options that appear, in the New Formatting Rule dialog box, click on
'Use formula to specify the cells you want to format' Enter the following formula in the formula field: =B2&lt;&gt;Jan! B2 In the Format Cells dialog box that appears, click the Fill tab, and then click the color that you want to highlight conflicting data. Click OK Click OK The steps above will immediately highlight changes to
the dataset for both tables. How does this work? Conditional formatting highlights a cell when a given formula in a cell returns TRUE. In this example, we compare each cell in one table with the corresponding cell in another table (done using &lt;&gt; equal to the cell in the operator in the formula). When conditional
formatting finds data, it highlights that in the Jan table (where we have identized conditional formatting). Please note that I have used a relative reference in this example (A1 $A $1 or $A 1 or A $1). When you use this method to compare two tables in Excel, remember the following. It is good to quickly identify differences
in this method, but you can not use it anymore. For example, if I type (or delete) a new row in a dataset, my results are incorrect. As soon as I add or delete a row, all subsequent rows are considered different and highlighted accordingly. You can only compare two tables in the same Excel file You can only compare a
value (not the difference in formula or formatting). Compare two Excel files/tables and use a formula to find differences If you just want to compare and quickly identify differences between two tables, you can use the formula to retrieve only those values that are different. For this method, you must have a separate
worksheet from which you can retrieve the differences. This work if you want to compare two separate Excel workbooks or worksheets in the same workbook. Let me give you an example where I compare two sets of data in two forms (in the same workbook). For example, either you have a dataset in a table named Jan
below (and according to similar information in a table published in February) and want to know which values are different. To compare two tables, first add a new worksheet (let's call this table Difference). In cell A1, type the following formula: =IF(Jan! A1&lt;&gt;Feb! A1,Jan Value:&amp;Jan!
A1&amp;CHAR(10)&amp;February Value:&amp;Feb! A1,) Copy and paste this formula into the range to cover the entire dataset in both tables. Because I have a small set of data, I only copy and paste this formula into the A1:B10 range. The formula above uses the IF condition to check differences. If there is no
difference in values, it returns blank, and if there is a difference, it returns the values in both tables in separate rows in the same cell. The good thing about this method is that it just gives you the differences and shows you exactly what the difference is. In this example, I can easily see that the price of cells B4 and B8 is
different (as are the exact values of these cells). Compare two Excel files/tables and get differences using VBA If you want to compare Excel files or tables quite often, it is a good idea to be ready for Excel macro VBA code and use it whenever you need to make a comparison. You can also add a macro to the Quick
Access Toolbar so that you can use it with a single button and immediately know which cells are different in different files or tables. Let's say you have two sheets in January and February and want to compare and highlight the differences in the Jan table, you can use the VBA code below: Sub CompareSheets() Dim
rngCell As Range For Each rngCell In Worksheets(Jan). UsedRange Unless rngCell = Spreadsheets(Feb). Cells(rngCell.Row, rngCell.Column) Then rngCell.Interior.Color = vbYellow End If Next rngCell End Sub The code above uses a For Next loop to go through each cell in the Jan table (the entire range used) and
compare it with the corresponding cell on the February sheet. If it finds a difference (which is checked using the If-Then phrase), it highlights these cells in yellow. You can use this code in a standard module in the VB Editor. If you need to do this frequently, it is better to save this code in the Personal Macro workbook,
and then add it to the Quick Access Toolbar. In these ways, you can make this comparison with the click of a button. To obtain a personal macro workbook in Excel, follow these steps (it is not available by default, so you must enable it). To save this code to a personal macro workbook And here you will find the steps to
add this macro code to QAT. Using a third-party tool - XL Comparator Another quick way to compare two Excel files and check the hits and differences is to use free party tool, such as XL XL This is a web-based tool where you can upload two Excel files, and it creates a comparison file with general data (or different data
based on the option you choose). For example, either you have two files with customer datasets (such as name and email address), and you want to quickly check what customers are in File 1 and not file 2. Below is how to compare two Excel files and create a comparison report: Open Download two files using the
Select File option (the maximum size of each file can be 5 T) Click next. Select a common column from both files. The tool uses this common column to search for a match and differences Select one of the four options, whether you want to get similar data or different data (based on file 1 or file 2) Click Next Download
comparison file with data (which option you selected in step 5) Below is a video showing how the XL comparison tool works. One concern you may have when using a third-party tool to compare Excel files is about privacy. If you have confidential information and privacy is really important to it, it is better to use the other
methods mentioned above. Note that the XL Comparator website mentions that they delete all files an hour after comparison. Use these methods to compare two different Excel files (or worksheets in the same Excel file). Hopefully, this Excel tutorial was useful. You may also like the following Excel tutorials: tutorials:
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